This project has moved and is read-only. For the latest updates, please go here.

versions of vss supported

Dec 18, 2012 at 7:10 PM

I want to migrate a vss database version 6 and I get a COM error.

Oct 10, 2013 at 12:59 PM
I too have the same problem. I wanted to migrate VSS database version6.0. I do not have VSS 2005.
Please help
Oct 10, 2013 at 6:45 PM
Hello,

You might have to make some minor code changes in order to do this.

Firstly, you'll have to remove the existing reference to ssapi.dll, then add a reference to the version of ssapi.dll that is contained in your SourceSafe 6.0d installation folder.

Then try and compile. If I remember correctly, you'll get a couple of compile errors, something about VssDatabase.Close - I don't think this method exists in the older version of SourceSafe. Just comment out these lines and see what happens.

Sorry I can't give you any more detail, but I don't have (any) version of SourceSafe installed and I deleted the testing VM's for this some time ago.

Regards;
Richard Moss